WordPress|WordPress Related Posts 3.6.4へ更新後の不具合

投稿者: | 2017-05-25

ワードプレス

プラグイン:WordPress Related Posts は、新しいバージョンがあります。3.6.3から3.6.4へ更新してくださいのメッセージで普段通り管理画面から更新後、ホームページを見ると

PHP Parse error: syntax error, unexpected ‘[‘, expecting ‘)’ in うんぬんかんぬん

(⑅∫°ਊ°)∫ アカン!

結論
「プラグイン WordPress Related Posts」を削除することで解決しました。

状況と対処
ホームページの画面、ワードプレスのログイン画面もこのエラーが出ました。プラグインメニューからプラグインを削除することができません。
このエラーメッセージは、”)”付近(直前)のソースコードに、想定外の “[“が存在することによって起こるもので、必要のない “[“が記述されているか、もしくは”]”が抜けているかが原因とか。

しかし、該当するコードが見当たらない。他に検索してみたら同じ様な状況の方が対処法を掲載されていたので参考にしました。このプラグインをサーバーから削除し解決です。
wordpress-23-related-posts-plugin 削除。

プラグイン削除の前にソースコードを訂正しても他に不具合が出るみたいですね。他にも対処法はあると思いますが、面倒臭がりの私には単純明解な方法を選び対応しました。

早朝から疲れましたw

==ランキング参加中です==
ブログランキング・にほんブログ村へ
==看板猫のことなど==


==徳島教室 新規入会募集中です==
徳島教室のページ
==和歌山教室 新規入会募集中です==
和歌山教室のページ
==沖縄三線に関するショップリスト==
Amazonストア楽天